We would like to notify you that the disturbance is now closed. If you experience any further delays, do not hesitate to contact your local support. Thank you for your patience and understanding.
Posted Nov 13, 2025 - 17:53 CET
Monitoring
Dear Customer / Partner,
We would like to inform you that the issue with viewing statistics on the MyLink 2.0 portal has been resolved.
Please note that any missing data may take up to 1 hour to become fully visible.
Our team will continue to closely monitor the services over the next 2 hours to ensure full stability. We appreciate your patience and understanding
Posted Nov 13, 2025 - 15:45 CET
Investigating
Dear Customer / Partner, We would like to notify you about an unscheduled system disturbance. Impact: We are currently experiencing an issue with viewing statistics on the MyLink 2.0 portal. Please note that all other services are operating normally.
Our team is actively working on a resolution. We apologize for the inconvenience and appreciate your understanding.
Posted Nov 13, 2025 - 15:26 CET
This incident affected: MyLINK Portal (Statistics).