[Intouch] Unscheduled disturbance

Incident Report for Link Mobility

Resolved

We would like to notify you that the disturbance is now closed.
If you experience any further disruptions, do not hesitate to contact your local support.
Thank you for your patience and understanding.
Posted Nov 03, 2025 - 10:29 CET

Monitoring

Dear Customer / Partner,

The impact is no longer present. InTouch platform will remain under close observation for the next 2 hours.
We plan to send you an update within the next 2 hours or when new information is available.
Posted Nov 03, 2025 - 08:22 CET

Investigating

Dear Customer / Partner,

We would like to notify you about an unscheduled system disturbance.

Impact: Customers may experience issues when accessing live.intouch.no.
We plan to send you an update when new information is available.

We apologize for the inconvenience caused.
Posted Nov 03, 2025 - 08:06 CET
This incident affected: MyLINK LookUp (InTouch) (Link InTouch Web, Link InTouch Lookup API).