We would like to notify you that the disturbance is now closed. If you experience any further issues do not hesitate to contact your local support. Thank you for your patience and understanding
Posted Jul 01, 2025 - 13:01 CEST
Monitoring
Dear Customer/Partner,
The supplier has implemented a fix, and the issue is now resolved.
We will continue monitoring the services closely.
Posted Jul 01, 2025 - 10:54 CEST
Investigating
Dear Customer/Partner
Please be informed that we are currently experiencing issues with the Intouch platform affecting address lookup for Swedish and Danish numbers.
Impacted service: Address Lookup for Danish and Swedish numbers. Please note that the lookup service for Norwegian numbers is working correctly.
Link Mobility is in contact with the supplier regarding this issue. We will keep you informed of any significant updates.
We sincerely apologize for any inconvenience this may cause and greatly appreciate your patience and understanding.
Posted Jul 01, 2025 - 09:28 CEST
This incident affected: MyLINK LookUp (InTouch) (Link InTouch Web, Link InTouch Lookup API).