We would like to notify you that the disturbance towards Telenor in Norway is now closed. If you experience any further delays do not hesitate to contact your local support. Thank you for your patience and understanding.
Posted 20 days ago. Apr 20, 2025 - 02:22 CEST
Monitoring
Dear Customer / Partner,
The impact is no longer present, Telenor Norway services will remain under close observation for the next 2 hours. We plan to send you an update within the next 2 hours or when new information is available.
Posted 21 days ago. Apr 20, 2025 - 00:14 CEST
Investigating
Dear Customer / Partner,
Please be aware that there is currently a disturbance towards Telenor in Norway
Start Date & Time: 2025-04-19 21:30 CEST Affected service: Delivery Reports Issue: Delivery reports may be delayed or missing
LINK is in contact with the operator. We apologize for the inconvenience caused and will provide more information when available.
Posted 21 days ago. Apr 19, 2025 - 22:35 CEST
This incident affected: Operators - Link Countries (Norway).