[Norway][Telia] Unscheduled disturbance

Incident Report for Link Mobility

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 10:42 CEST

Investigating

Dear Customer / Partner,

Please be aware that there is currently a disturbance towards Telia in Norway.

Start Date & Time: 2025-06-02 08:00 CEST
Affected service: Delivery Reports
Issue: Delivery reports are delayed.

LINK is in contact with the operator.
We apologize for the inconvenience caused and will provide more information when available.
Posted Jun 02, 2025 - 08:47 CEST
This incident affected: CGI (DLR) and Operators - Link Countries (Norway).