Notification of SMS Delivery Disruption

Incident Report for Link Mobility

Resolved

Dear Customer,
We would like to inform you of a brief disruption in SMS message delivery to Denmark.
Start Date & Time: 2025-03-19 14:11 CET
End Date & Time: 2025-03-19 14:27 CET
Affected Service: SMS
Issue: Message delivery failure

Due to technical issues we unfortunately had a period where a significant part of traffic to Danish recipients failed.
All services has already been restored.
We suggest resending any failed messages.
Posted Mar 19, 2025 - 14:10 CET