Unscheduled System Disturbance at MyLINK - Incident on 26.10.2025

Incident Report for Link Mobility

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 17:21 CET

Monitoring

Dear Customer / Partner,

The impact is no longer present. All services are operational and will remain under close observation for the next 2 hours.
We will send you an update as soon as new information becomes available.

Thank you for your patience and understanding.
Posted Oct 27, 2025 - 15:29 CET

Investigating

Dear valued Customer/ Partner

We would like to inform you that we are currently experiencing an issue with the statistics tab on MyLINK 2.0 portal, where statistics information are not updating as expected.

Please note that Mobile Originated, Mobile Terminated messages, and delivery reports are processed without any interruptions.

We are actively investigating the issue and working to resolve it as soon as possible. We will keep you updated with further information.
We apologize for any inconvenience this may cause and appreciate your patience.
Posted Oct 26, 2025 - 09:04 CET
This incident affected: MyLINK Portal (Statistics).