We would like to notify you that the disturbance is now closed. If you experience any further delays, do not hesitate to contact your local support. Thank you for your patience and understanding.
Posted Jun 19, 2026 - 20:35 CEST
Monitoring
Dear Customer / Partner,
The impact is no longer present; the services will remain under close observation for the next 2 hours. We plan to send you an update within the next 2 hours or when new information is available.
Posted Jun 19, 2026 - 18:30 CEST
Identified
Last update: We have identified that the issue is related to the ISP network. Our teams are actively working on mitigation actions while coordinating with the provider to restore full service.
Posted Jun 19, 2026 - 14:11 CEST
Investigating
Dear Customer/Partner,
We would like to inform you of an unplanned service disruption affecting the platform, caused by an external network connectivity issue.