We would like to notify you that the disturbance is now closed. If you experience any further delays do not hesitate to contact your local support. Thank you for your patience and understanding.
Posted Oct 18, 2025 - 12:13 CEST
Monitoring
Dear Customer / Partner,
The impact is no longer present, MyLINK Connect (Xenioo) services are operational and will remain under close observation until 2025-10-18 12:00 CEST. We plan to send you an update when new information is available.
Posted Oct 17, 2025 - 17:49 CEST
Investigating
Dear Customers,
We are currently experiencing intermittent issues affecting MyLINK Connect (Xenioo) services on the Europe nodes, due to network-related disruptions. Our engineering team is actively investigating the root cause and is working on a comprehensive solution to prevent future occurrences.
In the meantime, we are closely monitoring platform performance to ensure service continuity. We will continue to provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Oct 17, 2025 - 13:27 CEST
This incident affected: MyLINK Connect (Xenioo) (Europe).