[INTOUCH] Unscheduled Service Disruption

Incident Report for Link Mobility

Resolved

Dear Customer / Partner,

We would like to notify you that the disturbance is now closed.
If you experience any further delays do not hesitate to contact your local support.
Thank you for your patience and understanding.
Posted Jun 19, 2026 - 20:37 CEST

Monitoring

Dear Customer / Partner,

The impact is no longer present; the services will remain under close observation for the next 2 hours.
We plan to send you an update within the next 2 hours or when new information is available.
Posted Jun 19, 2026 - 18:25 CEST

Investigating

Dear Customer/Partner,
We would like to inform you of an unplanned service disruption affecting the InTouch platform, caused by an external network connectivity issue.

Start time: 2026-06-19 12:09 CEST
Affected Services:
SMS Mobile Terminated (MT)
SMS Delivery Reports (DLR)
Impact:
Customers may experience SMS submission failures, connection timeout errors, delayed message delivery, and delayed or missing delivery reports.

The issue is related to an ongoing external network connectivity incident and remains under investigation.
We apologize for any inconvenience caused and will provide further updates as they become available.
Posted Jun 19, 2026 - 16:28 CEST
This incident affected: MyLINK LookUp (InTouch) (Link InTouch SMS API).