[Ireland][Horisen] Unscheduled disturbance

Incident Report for Link Mobility

Resolved

Dear Customer / Partner,

Please be aware that there is currently a disturbance towards Horisen in Ireland.
Start Date & Time: 2025-10-21 19:00 CEST
End Date & Time: 2025-10-21 22:05 CEST
Affected service: SMS
Issue: Delayed/missing SMS

Our engineers are actively investigating the issue and maintaining direct communication with the operator.
We apologize for the inconvenience caused and will provide more information when available.
Posted Oct 21, 2025 - 21:54 CEST