[2026-09-07][InTouch] Address Lookup Functionality - Unscheduled Disturbance

Incident Report for Link Mobility

Resolved

Dear Customer / Partner,

We would like to notify you that the disturbance is now closed.
If you experience any further delays do not hesitate to contact your local support.
Thank you for your patience and understanding.
Posted Sep 07, 2026 - 11:14 CEST

Monitoring

Dear Customer / Partner,

The impact is no longer present. The Lookup API on the InTouch platform will remain under close observation for the next 2 hours.
We plan to send you an update within the next 2 hours or when new information is available.
Posted Sep 07, 2026 - 08:55 CEST

Investigating

Dear Customer / Partner,
We would like to notify you about an unscheduled system disturbance affecting the Address Lookup functionality on the InTouch platform.

Affected service:
- InTouch Lookup API

Impact:
The Address Lookup functionality is currently unavailable. As a result, requests to the InTouch Lookup API may fail and customers may be unable to perform address lookups.

We apologize for any inconvenience caused and will provide further updates once more information is available.
Posted Sep 07, 2026 - 08:34 CEST
This incident affected: MyLINK LookUp (InTouch) (Link InTouch Lookup API).