[Finland][Telia] Unscheduled disturbance

Incident Report for Link Mobility

Resolved

Dear Customer / Partner,

We would like to inform you that the issue has been resolved, and no further impact is observed.

We apologize for the inconvenience caused.
Posted Aug 26, 2025 - 15:37 CEST

Investigating

Dear Customer / Partner,

Please be aware that there is currently a disturbance towards Telia in Finland.

Start Date & Time: 2025-08-26 14:15 CEST
Affected service: Delivery Reports
Issue: Delivery reports may be delayed or missing

LINK is in contact with the operator.
We apologize for the inconvenience caused and will provide more information when available.
Posted Aug 26, 2025 - 15:08 CEST
This incident affected: Operators - Europe (Finland).