[INTOUCH][2026-05-20] Unscheduled Service Disruption

Incident Report for Link Mobility

Resolved

This incident has been resolved.
Posted May 20, 2026 - 11:26 CEST

Monitoring

Dear Customer / Partner,

The issue affecting customer logins to the InTouch platform has been resolved.

Services are now operating normally, and customers should be able to log in without issues.

We apologize for any inconvenience caused and appreciate your patience.
Posted May 20, 2026 - 09:01 CEST

Investigating

Dear Customer / Partner,

We would like to inform you about an unscheduled service disruption.

Impact: Customers may experience issues logging in to the InTouch platform (https://live.intouch.no).

Our team is currently investigating the issue and working to identify the root cause.

We will provide an update as soon as more information becomes available.

We apologize for any inconvenience caused.
Posted May 20, 2026 - 08:41 CEST
This incident affected: MyLINK LookUp (InTouch) (Link InTouch Web).