[Norway][ICE] Unscheduled disturbance

Incident Report for Link Mobility

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:34 CEST

Monitoring

Dear Customer / Partner,

The impact is no longer present, ICE in Norway will remain under close observation for the next 2 hours.
We plan to send you an update within the next 2 hours or when new information is available.
Posted Oct 20, 2025 - 11:18 CEST

Investigating

Dear Customer / Partner,

Please be aware that there is currently a disturbance towards ICE in Norway.

Start Date & Time: 2025-10-20 10:00 CEST
Affected services: MT messages and Delivery Reports.
Issue: Delayed MT messages and delivery reports.

LINK is in contact with the operator.
We apologize for the inconvenience caused and will provide more information when available.
Posted Oct 20, 2025 - 10:25 CEST
This incident affected: Operators - Europe (Norway).