[Sweden][Tele2] Unscheduled disturbance

Incident Report for Link Mobility

Investigating

Dear Customer / Partner,

Please be aware that there is currently a disturbance towards Tele2 in Sweden.

Start Date & Time: 2026-06-17 15:23 CEST

Affected service: SMS
Issue: Mobile Terminated messages and Delivery reports may be delayed or missing.

LINK is in contact with the operator.
We apologize for the inconvenience caused and will provide more information when available.
Posted Jun 17, 2026 - 15:34 CEST
This incident affects: Operators - Europe (Sweden).