[Norway][ICE] Delayed delivery reports

Incident Report for Link Mobility

Monitoring

Dear Customer / Partner,

The impact is no longer present. ICE Norway will remain under close observation for the next 2 hours.
We plan to send you an update within the next 2 hours or when new information is available.
Posted Apr 29, 2026 - 12:44 CEST

Identified

Dear Customer / Partner,

The disturbance is still ongoing.
In addition to the initial impact, it was found that Mobile Terminated (MT) messages are also affected, and could be delayed or missing.
We plan to send you an update within the next 2 hours or earlier if new information is available.
We apologise for the inconvenience.
Posted Apr 29, 2026 - 12:33 CEST

Investigating

Dear Customer / Partner,

Please be aware that there is currently a disturbance towards ICE in Norway.

Start Date & Time: 2026-04-29 11:40 CEST
Affected services: Delivery Reports
Issue: Delivery Reports may be missing or delayed.

LINK is in contact with the operator.
We apologise for the inconvenience caused and will provide more information when available
Posted Apr 29, 2026 - 12:26 CEST
This incident affects: Operators - Europe (Norway).